Geneve V2.00 BIOS Update

The original V0.98 Boot Eprom with Swan for the Geneve has been updated to V2.00 to include the ability to boot from Ramdisk, Myarc HFDC, SCSI, IDE, TIPI, and Floppy in that specific order.

If you will be using this eprom with a TIPI system, you must upgrade to v2.23 or later for the PI, and you must use the TIPI Eprom released on 4-19-2021. Earlier versions of the TIPI eprom are not 100% compatible and may result in lockups or no access to the TIPI when used with the Geneve V2.00 eprom.

Due to limitations with the TIPI for filenaming, the file SYSTEM/SYS should be copied as SYSTEM-SYS. By copying the file rather than renaming the file, should you find the eprom binary not working to your satisfaction you can simply swap back to your original eprom. This eprom update only looks for the specific LOAD-xxx files below and SYSTEM-SYS whether it be on the Horizon Ramdisk, HFDC, IDE, SCSI, TIPI, or DSK device.

This eprom update is not necessary if you are a Horizon Boot disk user. Nor, should you attempt to use this binary on a PFM or PFM+ system. If you are a user seeking to boot from an IDE or TIPI drive versus a DSK1. floppy drive, then this update should be considered. SCSI users, unless seeking to boot from a TIPI are likely using the Tony Knerr V1.0 eprom and would unlikely need to update.

There is a discussion topic on Atariage and Bob Carmany is offering the eprom for $7 which includes shipping if you want to test the beta eprom on your system.

PFM and PFM+ users do NOT need this update.

https://www.9640News.com/Files/GeneveBootEprom200.zip

This release presents the original Geneve Swan in its display.

Leave a Reply

Your email address will not be published. Required fields are marked *